No components marked as affected
Resolved
We believe this issue is now resolved. All previous payments and all future payments should now be correctly applied to all servers. Please contact us if this issue persists.
Identified
We have identified the issue and have pushed a fix for all future payments. We are currently working on fixing all previous payments.
Investigating
We are currently experiencing issues with some payment orders not processing correctly. We are currently investigating the issue, and will retroactively fix all broken payments.